Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.
Output Specification:
For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.
Sample Input:
10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5
Sample Output:
1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
solution:
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define endl '\n'
int main()
{
int n,k;cin>>n>>k;
vector<vector<string> >v(k+1);
for(int i=0;i<n;i++)
{
string name;cin>>name;
int t;cin>>t;
while(t--)
{
int cnt;cin>>cnt;
v[cnt].push_back(name);
}
}
for(int i=1;i<=k;i++)
{
if(v[i].size())
{
sort(v[i].begin(),v[i].end());
cout<<i<<' '<<v[i].size()<<endl;
for(int j=0;j<v[i].size();j++)
{
cout<<v[i][j]<<endl;
}
}
else//测试点1:没人选的课程也要输出
{
cout<<i<<' '<<0<<endl;
}
}
}
一个简单的二维vector数组排序。
测试点1:没人选的课程也要输出
本站资源均来自互联网,仅供研究学习,禁止违法使用和商用,产生法律纠纷本站概不负责!如果侵犯了您的权益请与我们联系!
转载请注明出处: 免费源码网-免费的源码资源网站 » 1047 Student List for Course——PAT甲级
发表评论 取消回复